Case-Sensitive host name remote backup location will not work -> use all lower case

Feedback on a Problem or for Improvement

Looks like known_hosts will store hostname in lowercase, so do not enter them in upper or mixed case in the gui.

As I had to re-install freedombox due to my own carelessness (don’t ask it was stupid) I was thinking remote backup sounded like a very good idea.
On setting up I entered the remote location like this
this lead to the following error “ not found in known_hosts …” on checking it, I found that it was there (in /var/lib/plinth/.ssh/known_hosts) but it was there in lower case. on a whim i tried entering the hoste name all in lower case ( and lo and behold works like a charm

Proposed Solution
Maybe automatically convert the entry from the user to all-lowercase?

While i’m at it: I think it would be very nice to also allow a user to specify paths that they want to include in the backup. This way they could easily backup their own data in addition to the freedombox-apps and their (config) data.

@auser I agree, that would be a nice feature!

In the meantime, setting up rsync as a cron job isn’t too difficult if you have a few folders you want automatically backed up. This guy wrote up a very basic how-to:

You can set up rsync over SSH too, if you want the backup to be sent to a remote machine. That’s a little more involved (you have to set up the keys and passwordless login and stuff), but it’s certainly an option if that’s what you want.