Can't get to freedombox.local - is there an issue with a Debian update?

If you are asking for support for an issue, please include the following information at the top of your post:

I have had a freedombox since March 2023. My Freedombox is plugged into my router. No static IP address. Set up worked fine- eventually… Now, I cannot get to FB from my browser. Message is “having problems connecting…” The FB is online and I tested connectivity via the ping “method”. I am just now training myself on the basics of networks (I use a Mac OS computer) which presented difficulties initially and learning about terminal commands (in Mac OS). So … eventually I want to switch to the GNU/Linux OS for security and privacy reasons and prior to that use FB to set up a VPN … ( I now use Proton VPN). I have been hopeful about the FB community and its goals but …

So, I have 3 questions:

  1. What s going on and what can I do?

  2. Is there anybody else out there who is lost in all of the technical issues that get raised ?

  3. Is there a Forum section on FB for “dummies”? I only “dummies” mean this in the sense that one is like me is not yet trained but smart enough & wants to learn?

Finally, I mean no disrespect to the very impressive comments made by members of this community.

  • Whether your FreedomBox is plugged into a router at home or not (if not, please specify how it is connected to the internet)
  • The month and year you bought your kit (feel free to omit if you want to preserve some privacy, but this could be helpful information)
  • The version of FreedomBox your are running (available by clicking on the “?” in the top menu → “About”)
1 Like

Have you tried any of the following?

-Clear your browser history and cache
-Check firewalld’s config and make sure it says defaultzone=external
-Find out what the local IP address is from your router for your FreedomBox. Under connected devices, with will often show up as ‘freedombox’.
It will usually start with 192.168… You can type this number in the URL insteal of freedombox.local.

I know I had problems accessing Plinth when FreedomBox stable changed to Bookworm from Bullseye. Forcing all of the packages to update solved this problem for me.

-SSH into the FreedomBox and use sudo apt update && sudo apt full-upgrade. You may have to do this a number of times, or install packages which get held back manually by specifying them, such as ‘sudo apt install freedombox’, for example.


I can only connect to my FreedomBox Pioneer via “freedombox.local” for about 2-3 minutes after starting it, since i upgraded it to Debian GNU/Linux 12 Bookworm.
It can still be accessed via IP-address, and the domain-name for it.

It seems that “avahi-daemon” is not working correctly.
Using the following command will make “freedombox.local” available for 2-3 minutes again:
sudo systemctl restart avahi-daemon.service

There is an old bug-report on the Debian Bug Tracking System about this:

Having this same experience.

I did notice that it seems to be firewall related somehow, since stopping/restarting firewalld.service also makes “freedombox.local” work until it’s restarted.

This is after I made sure that DefaultZone=external is set in firewalld’s configuration.

Thank you for taking the time to help.

  1. I did know the IP address of the Freedom box. So, from my Mac OS machine, I used the Terminal program (Mac) to login successfully. I could not login using “SSH admin@freedombox” but I could login with the command "SSH admin@[my ip address] if that helps those who know this stuff to figure out the problem.
    But still no access from my browser.

  2. So, I then entered the commands you suggested with this result:
    admin@freedombox:~$ sudo apt update
    [sudo] password for admin:
    Get:1 Index of /debian-security stable-security InRelease [48.0 kB]
    Hit:2 Index of /debian stable InRelease
    Get:3 Index of /debian stable-updates InRelease [52.1 kB]
    Get:4 Index of /debian bookworm-backports InRelease [49.7 kB]
    Get:5 Index of /debian-security stable-security/main Sources [31.6 kB]
    Get:6 Index of /debian-security stable-security/main armhf Packages [45.7 kB]
    Fetched 227 kB in 8s (28.4 kB/s)
    Reading package lists… Done
    Building dependency tree… Done
    Reading state information… Done
    All packages are up to date.

  3. Then I entered the following command you suggested:
    admin@freedombox:~$ sudo apt full-upgrade
    Reading package lists… Done
    Building dependency tree… Done
    Reading state information… Done
    Calculating upgrade… Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    admin@freedombox:~$ sudo apt install freedombox
    Reading package lists… Done
    Building dependency tree… Done
    Reading state information… Done
    freedombox is already the newest version (23.6.2).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  4. I still am unable to access the FB webpage from my browser (and I cleared all data in preferences).

I see others have had an issue like this as well. I hope this might help.

Thank you

Thank you for your time. I just responded to Said with the results of following his suggestions. But as to your suggestion, I’m just not familiar enough to understand.

But thank you again


My previous message was not a suggestion for how to solve it; i just have either the same, or a similar problem, so i added some more information about it, to help find a solution for it.

Currently, there are multiple problems that can prevent one from accessing ones FreedomBox:

Problem 1 - DefaultZone in the firewalld-config is wrong

One problem, that many people seem to have, is, that during the upgrade from “Debian GNU/Linux 11 Bullseye” to “Debian GNU/Linux 12 Bookworm”, people choose the “new config-file from the maintainer” for firewalld, instead of keeping the existing config, when asked about it during the upgrade (when upgrading with sudo apt full-upgrade).
Using the config from the maintainer will change DefaultZone=external to DefaultZone=public.
The firewall of the FreedomBox will not work correctly anymore after that.
This prevents people from accessing their FreedomBox via a web-browser, and maybe other connections too.

This problem can be solved by opening the “firewalld”-config on the FreedomBox with
sudo nano /etc/firewalld/firewalld.conf, and making sure, that the DefaultZone is
DefaultZone=external (edit the file, if necessary, and then save the file with CTRL + S, then exit nano with CTRL + X).
After restarting the firewalld-service with sudo systemctl restart firewalld.service,
or restarting the entire FreedomBox with sudo shutdown -r now, it should work again.

If connecting via SSH does not work, one can still connect a monitor and a keyboard to the FreedomBox to access it directly.

Problem 2 - “freedombox.local” is unavailable

Another problem is, that connecting via “freedombox.local” does not work anymore, after upgrading to Bookworm.
I have this problem with my FreedomBox.
I can still connect to my FreedomBox, with a web-browser, by entering the local/public IP-address of my FreedomBox, or the public domain-name i have set up for it; but “freedombox.local” won’t connect to my FreedomBox.

I do not know a solution for this problem.

Usually, avahi-daemon, which is running on the FreedomBox, announces a service at the “freedombox.local”-address (via mDNS/DNS-SD) in the local network, so that web-browsers connect there, when opening “freedombox.local”.

It seems that avahi-daemon only announces the services once after starting.
I can then use “freedombox.local” to connect to my FreedomBox for 2-3 minutes after avahi-daemon started, because the announcement is cached on my PC.
After that, “freedombox.local” will not be available anymore.