Cannot Login to FreedomBox

If you are asking for support for an issue, please include the following information at the top of your post:

  1. My FreedomBox is plugged into a router.
  2. My router has a public IP address which that may change over time.
  3. I bought FreedomBox in Jan 2023.
  4. I updated FreedomBox successfully and then installed the Apps successfully. However, I did not remember & did not receive a notice to “…obtain a Let’s Encrypt certificate.”
  5. I logged out of Freedombox.local and now I cannot log back in. I know I entered the correct Username and pretty sure I got the password correct too. I entered what I had wriiten down.
  • Whether your FreedomBox is plugged into a router at home or not (if not, please specify how it is connected to the internet)
  • The month and year you bought your kit (feel free to omit if you want to preserve some privacy, but this could be helpful information)
  • The version of FreedomBox your are running (available by clicking on the “?” in the top menu → “About”)

Do you mean that

  • you have setup a username/password for admin, as asked by the web interface
  • you can still access the web interface, but when you try entering that username/password again, you’ve got the message “please enter a valid username/password, note that username/password are case sensitive” (I tried translating to English what I have in another language so the wording may not be that exactly).


Yes - that is exactly correct. Thank you so much for taking your time to help.

Do you have your keyboard configured in another language than English?

What happened to me sometimes is that when I entered a password, the keyboard layout that applied was not what I thought (US instead of French) so the password I have set is not what I thought I had set, I printed a US keyboard layout to find out what password I had actually typed.

If that is not the problem, then I don’t know what could have happened. My suggestion would be to switch your device off and put the microSD card in a reader in another computer preferrably running a GNU/Linux system. Two options then:

  • option 1: mount the microSD card, chroot to the mount point, then “passwd your-username”
  • option 2: make a fresh install microSD card (to start again from the begining)

For option 1: I have not tried, so do that only if you know what you are doing.
For option 2, you need to:

  1. Download the image using the link at Pioneer Edition FreedomBox | FreedomBox - Personal Server at Home
  2. Write it to the microSD card as explained at FreedomBox/Download - Debian Wiki (xz and dd commands)

Thank you so very much for your help. I will start over and try option 2. When I began, I was using a wireless keyboard and wireless mouse on an iMac. The mouse kept turning off. I then switched to a wired keyboard and wired mouse. I believe I entered an administrator user Id and password with the wired devices but, at this point, who knows. Time to start over. Thank you again.

I did a fresh install on a microSD card and started over. It worked. I am now able to login to the freedom box. So, that problem is solved. I forgot to post this. Thanks.