Cannot flash Freedombox to SD card

Problem Description
I am following the setup instructions in the video on the Freedombox Download page. I am attempting to flash the latest image (freedombox-testing-free_latest_all-arm64.img) to a brand new micro SD card to use in a Raspberry Pi 4-B. However, when I attempt to flash the image in Etcher, I receive the error message captured in the attached screenshots (it only let me upload 1). I have tried everything I can find on the internet and have found nothing but frustration.

I am using a MacBook Pro running macOS Catalina 10.15.6 to format and flash the SD card.

Steps to Reproduce

  1. Go to the official Freedombox download page, select my compatible hardware (Raspberry Pi 4-B), and download the latest image,
  2. Unzip the downloaded .img file
  3. Download and install balenaEtcher
  4. Insert blank micro SD card (Netac 128gb microSDXC)
  5. Open Disk Utility, select the SD card, select “erase,” set format to MS-DOS (FAT). (I’m guessing here, based on the options)
  6. In Etcher, select the .img file as the flash file, select the SD card as the target, click “flash.”
  7. Warning prompts me to grant Etcher privileged access in order to flash disks. Enter my user password.
  8. Error message (see screenshots). If I select “retry” the same thing occurs.
  9. The strange part - if I click “cancel” and then run the process again, the error does not appear and it seems to work! After a couple minutes of loading, Etcher tells me that the image has been flashed successfully. However, when I view the SD card in Disk Utility, I do not see any new volumes, as I understand I should.
  10. Connect the Raspberry Pi to my network switch, then power supply, then wait 10 minutes. Then 20 minutes. Nothing. “freedombox.local” yields a “server unavailable error.” It seems the SD card was not in fact actually flashed.

Is the Freedombox image file corrupted, as the error supposes? I’ve tried 4 or 5 different image files at this point with the same results and find it hard to believe that they would all be corrupted. Is the fancy SD card I bought for this purpose incompatible or formatted incorrectly? Am I missing something obvious? I’m out of ideas.

I can cd and ls my way around a command line if I have to, but I’m definitely not tech savvy enough to build something from the source code. A lot of what I’m seeing in the Freedombox manual is not very helpful. A sentence like “On the web, there is a lot of documentation about setting your device up and flashing USB or SD Cards to boot your hardware” has no place in an instruction manual for a technology ostensibly designed very specifically for non-technical users.

Any and all help is welcome and much appreciated! Thanks in advance!

Update: I have tried the same procedure on a Windows 10 PC and the Freedombox image still does not appear to flash to the SD card. When I double click on the .img file, I am notified that the file is corrupted. I have attempted this with several different downloaded Freedombox .img files, using both Etcher and Rufus to flash the card. The problem does indeed appear to be with the image files themselves, which is something I have no control over. Am I just out of luck? How do I get an intact version of the image file for the Raspberry Pi 4 if not from the Raspberry Pi 4 download page? I would really appreciate some kind of guidance from someone. Thanks.

I don’t know macOS, you could try to check the signature of your downloaded image as given on the download page.

There may also be something wrong with etcher, maybe try it on the command line. Maybe try searching for “macos sdcard image terminal window”. If you find it helps, you could carefully improve the manual by editing the wiki:

Further update: At this point I have tried 3 different image flashing methods (Etcher, Rufus, and RosaImageWriter) using 3 different image files (latest Raspberry Pi 4 testing image, latest Raspberry Pi 4 stable image, and the latest Raspberry Pi 3 image), on 2 different computers and operating systems (Macbook and Windows 10 PC).

(I also tried entering the terminal commands in the instruction manual but I just receive errors about them not being recognized commands.)

I specifically purchased this micro SD card according to the available instructions, so I don’t think I’m asking Freedombox to accommodate any compatibility it isn’t meant to.

Thus, I am fairly confident by now that the problem is not on my end but rather with the image files themselves. Could someone please help me verify this suspicion by downloading the image files and inspecting to see if they are consistently corrupted, as they seem to me to be every single time? And if that is the case, how does this get fixed? Thanks

As your error actually says that /dev/rdisk2 is “busy or locked” maybe you need to unmount the filesystem or switch that latch on the SD card before writing? (I don’t use tools like etcher.)