Brand new FreedomBox, blank website

I purchased a brand new Pioneer FreedomBox ( from Olimex, unpacked it and plugged it in. I discovered where it was on my network using nmap. However it doesn’t show what’s in the setup manual, with the Apache version.

What I expected to see:

 Nmap scan report for
 Host is up (0.00088s latency).
 80/tcp open  http    Apache httpd 2.4.17 ((Debian))

What I actually see:

Nmap scan report for
Host is up, received syn-ack (0.0036s latency).
Scanned at 2020-05-19 13:06:42 AEST for 173s

80/tcp open  http    syn-ack

When I browse to, all I see is a blank screen. The port seems to be open but nothing’s answering.

Anyone know what’s up with this?

1 Like

Is it possible for you @alexbayleaf to give some more informations about your network environment ?

  • is there a ISP box or router ?
  • what is the IP address set or get by your computer (the one used with nmap) ?

I would be pleased to help.

Thanks @fred1m!

I have an ISP router at When I run nmap I see the web admin interface on port 80 there.

My laptop is connected to the router via wifi, and my laptop’s IP is

My Pioneer FreedomBox is plugged into the ethernet port on the back of the ISP’s router. Its IP address is

When I visit in my browser (latest Firefox on OSX) I see a blank screen.

Could you try with https @alexbayleaf ?

Oh, just a thought… the setup guide says it takes ~10 minutes to initialise everything. When I first plugged it in, I was using an international power converter as I’m in Australia, and it was a little bit unsteady. I may have bumped it and rebooted it mid-initialisation. Could that cause what I’m seeing? If so, will I need to follow the instructions at to re-create the disk image?

(Note: I’m comfortable with command line, but right now my only computer is a Macbook without an ethernet port. I do have a MicroSD->USB thingy that I can use to read/write MicroSD cards. Just to let you know where I’m at.)

Secure Connection Failed

An error occurred during a connection to PR_END_OF_FILE_ERROR
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the web site owners to inform them of this problem.

You may trust self-signed https certificat.

It’s not giving me an option to. I don’t think this is a self-signed cert issue, I think this is a gibberish-(or-nothing)-on-port-443 issue.

Note: I am not running any kind of VPN or proxy that should be getting in the way here (the most common cause of this issue, according to the googles) and I haven’t been messing with any SSL-related settings in firefox.

Chrome sees this:

This site can’t be reached took too long to respond.


  • Checking the connection
  • Checking the proxy and the firewall


Also, I ran an HTTP header inspector as I made the request, and there’s no response coming back from the FreedomBox. Definitely nothing there - port 80/443 are open, but nobody’s home.

So… am I missing something major here? Because I just looked more closely, and there’s no MicroSD card in there. I’m pretty sure there was meant to be one. I’ll be having a chat to Olimex I guess!

Oh my god. I’m an idiot. THE CARD WAS STUCK TO THE OUTSIDE OF THE BOX. I didn’t even see it there, and assumed it was already in place.

Never mind, hopefully it will boot up much better once it has an actual file system! headdesk


Well, I guess we’ve learned a new failure mode:

My Pioneer FreedomBox shows a blank screen when I point my web browser at it
Did you install the MicroSD card before booting it up? It’s taped to the outside of the box it came in.

This… this is why I’m a software person.

1 Like

I am happy it finally worked for you. At the very least you got to know the community.

1 Like