Botched upgrade via Plinth. Cannot use command line upgrade

My freedombox has been online for 6 months, working perfectly. I prefer not to do auto-upgrades or do them frequently if all working well. Today I decided to do an upgrade via the Plinth graphical interface. It took forever and threw lots of WARNINGS such as:

2023-07-21 11:48:04,019 WARNING package uwsgi-plugin-python3 upgradable but fails to be marked for upgrade (E:Unable to correct problems, you have held broken packages.)

Then the web interface failed with a 500 error. I decided to login via ssh and repair the upgrade. However, I now get:

pam-abl: BDB2506 file /var/lib/abl/users.db has LSN 7403/800842, past end of log at 7403/708508
pam-abl: BDB2507 Commonly caused by moving a database from one database environment
pam-abl: BDB2508 to another without clearing the database LSNs, or by removing all of
pam-abl: BDB2509 the log files from a database environment
pam-abl: BDB1579 Database handles still open at environment close

and attempt to manually update with this info: FreedomBox/Manual/Upgrades - Debian Wiki
and dpkg --configure -a throws:

dpkg: error: dpkg frontend lock was locked by another process with pid 15892
Note: removing the lock file is always wrong, and can end up damaging the
locked area and the entire system. See

I am unsure how to proceed. Otherwise the system is working fine, but updating does not seem like an option now. Any help appreciated…


You probably aught wait it out a bit. Might have a number of packages to replace and its just chugging along. The low-power hardware especially shows its limitations when doing large updates.

I don’t suppose you made backups prior to attempting this upgrade? Just in case?

I believe I found a solution here to recover the pam-abl database. No guarantees but it worked for me.

sudo apt install db5.3-util
sudo db5.3_verify -h /var/lib/abl hosts.db 

if verification gives error (should be same error as you shared above) then,

sudo db5.3_recover -v -h /var/lib/abl

Hope it works. Good luck.

1 Like

I just noticed that problem in the journal and this solved it. Thanks !