503 Service Unavailable: Plinth Problem?

Hello, everyone! Newbie here.

Before I begin, here’s some background information.

  • My Pioneer FreedomBox is plugged into a router at home.
  • I’d bought it a few months ago, but I’ve got it up and running about a week ago.
  • It’s running Debian GNU/Linux 10 (Buster) and FreedomBox 20.12.

This problem has been happening for a few days. I haven’t done much with my Pioneer FreedomBox so far, and I don’t remember anything I’ve done that might’ve caused it. When I enter “freedombox.local” into my browser’s address bar, I’m taken to “https://freedombox.local/plinth”. That page’s title says “503 Service Unavailable”, and its text says:

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.38 (Debian) Server at freedombox.local Port 443

I’ve waited and tried again multiple times, and that didn’t work. I’ve rebooted my modem, router, and Pioneer FreedomBox multiple times, and that didn’t work either. However, I’m able to SSH into my Pioneer FreedomBox. I’ve performed updates and upgrades like so:

$ sudo su -
$ apt-get update
$ apt-get dist-upgrade

That didn’t work either, but this did:

$ plinth

Now “https://freedombox.local/plinth” works again, but only when there’s an active SSH connection and manually launched Plinth running in a terminal. What do I need to do to make it “just work” like before?

Please see [FB 20.12][Solved] Plinth fails to start due to new frontpage.py shortcuts and filesystem permissions.