Unable to get Freedombox to work

I have been frantically trying to get Freedombox up and running for several weeks now and still no luck.

I have tried both in a Virtual machine and on a desktop PC

Installed Debian 10 Buster as a guest in a Virtual machine on Windows 10
From within Debian opened terminal
sudo apt-get update
sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox
Everything seemed to install OK
Rebooted and still in Debian
So used Synaptic Package manager and installed Freedombox and extras required
All seemed to install OK
Reboot and back in Debian
Cannot figure out how to get into Freedombox from this point on.

My real aim is to run Freedombox from a spare PC i have.

I installed Debian 10 Buster onto the PC using a DVD
Now when i try Synaptic Package manager i get a message
""The repository’cdrom://[Debian GNU/Linux… etc does not have a release file
I cannot figure out why my PC is not looking for an update server. Why is it looking for updates on my install DVD
Totally confused.

Looks like i have an internet connection problem. Just about to install windows 10 and see if that connects to internet

Please follow the instructions on the following page to install FreedomBox using VirtualBox. If you use the official VirtualBox image for FreedomBox, your installation should work whether you have an internet connection or not.

Thank you for your prompt help.
I will try this tomorrow as it is early am here at the moment
I would still like to use my older desktop and tomorrow i will get a wireless usb to see if that solves the internet connection problem

A journalist for TechRepublic also recently wrote an article about this. You should check it out:

“How to run FreedomBox as a VirtualBox VM”

I am stuck on “Connecting to Freedombox”
What is the web address i am looking for?
The article says the address is https://freedombox
But it cannot be found as there is no dot something
Downloaded Chrome = no better
Searched Freedombox org and Foundation sites and cannot find user creation page

I tested running the stable (Buster) image in Virtualbox with Bridged Adapter setting. I’m able to access https://freedombox both from the host machine, and from a phone on the same network. Have you tried this?

https://freedombox or https://freedombox.local might not work on Windows 10.

You should check your router’s list of connected clients to find the IP address of the FreedomBox.

Thank you for giving me all this help. It is much appreciated.
I am no geek, i am just interested in trying new things and struggle through.
I have no idea what to expect once i get Freedombox up and running but hopefully i can make good use of it.
I have Virtualbox on a Windows 10 PC and i now have Freedombox running up to the log in screen as a guest OS
I just need to get those login details.
I described earlier i was unable to find the necessary website. This sounds like it is because i am attempting access from a Windows 10 PC and i should be using Debian.
Sounds also like i should be able to create an account from any installed Debian OS either virtualised or stand alone.
For speed i will install Debian as a guest OS on this Windows 10 PC. Hopefully i will then get all my login details sorted then run my Freedombox. All from the same pc


  1. Your computer is connected to a router at home using WiFi. In case not, this guide would not be a great help.
  2. You have installed FreedomBox on virtual box using wiki provided
  3. You are able to see a login prompt in the virtual box after booting the virtual machine.

Things to follow:

  1. Stop the virtual box instance, goto settings of that virtual machine and check network tab to see if you have selected bridged adapter.(steps are provided in wiki already).
  2. After setting the bridged adapter, save(apply) settings and start the virtual machine
  3. After you see a login prompt, minimise the virutal machine application.
  4. Now its time to know the ip address of freedombox(virtual machine). For this, you can use AngryIPscanner or use the FreedomBox Android app or guess the ip. Follow below steps to guess the ip address
  • Follow this article to find your windows system ip address
  • You might find the ip address of type 192.168.y.x or 192.168.y.x. Here x could be 1,2,3 … depending on the devices connected to your router and y could be either 0 or 1. Now, its time to guess the ip address of freedom(virtual machine). open a browser(chrome or firefox etc) and type in the address box https://192.168.y.2 - replace y with 0 or 1 depending on the value you have found above from your ip address.
  • You should get a webpage as shown in the wiki link given above. In case you did not get one, try with another ip address https://192.168.y.3 then 4 then 5 until you reach freedom box

Once you have found the freedombox, follow the rest of the wiki to set it up.

1 Like

1 = Y
2 = Y
3 = Y
Network set as per Wiki with Bridged adapter
Still trying

Finally in. Got in with angry ip scanner. Wish i had used earlier
Now i will follow rest of instructions

Now i have messed up again.
Got in through ip address then logged out. Logged into Freedombox through virtual machine but i cannot get from terminal to graphical interface

There is no graphical interface inside virtual box. Expectation here is, users to configure freedombox through the web interface(the way you have logged in from your browser(chrome/firefox etc)

I’ll add in another trap for users here, is that modern versions of the Chrome browser don’t let you connect to “insecure” sites with invalid certificates. I could not connect to my new Freedombox server with Chrome (not even an option to “proceed ignoring the browser warning”)- instead I used Safari browser.

I can still find this option in Chromium 80

1 Like

Interesting. Here is my message:

You can see there is no way to proceed. (Chrome for Mac Version 81.0.4044.92)

1 Like

The errors in both the cases are different. One is CERT_INVALID (for which there is not option to ignore) and the other is CERT_AUTHORITY_INVALID (can be ignored). What happens if you try to access using a domain name like freedombox.local?