[SOLVED] FreedomBox disappeared from network list in router

My freedomBox works ok.
I was reading and experimenting this tutorial - FreedomBox for Communities/Network Configuration.

  1. Changed corrent connection firewall zone to ‘Externa’
  2. Add LAN connection ipv4 to

And save it then lost connection.
So I tried reconnect(unplug and plug it again) then checked in router page. But there is no FreedomBox.
I tried restart FreedomBox and Router. It didn’t work.

What am I missing? How can I find a problem even I can’t connect to freedombox?

I may have run into a related problem when I changed my router’s local network addressa and forgot to change the static IP address of a second freedombox I had on my network. See if this works - Disconnect from the router and connect directly to your Freedombox using a manually set IP address for the computer you’re connecting with, say,

1 Like

The setup described in the book is assuming that FreedomBox two network interfaces. One for connecting to the Internet (via a modem or so) and the second one for distributing the connectivity to various devices on the network (like a Wi-Fi router at home does). LAN connection is the latter. In this case, FreedomBox itself assigns itself IP address and starts distributing IP addresses to other devices on that network IPs starting with 10.42.1. .

Your FreedomBox likely only has 1 network interface and is probably connected to a Wi-Fi router which is already in-charge of distributing IP addresses in the network. It probably gives out IP addresses in the range 192.168.0.x. Your FreedomBox assigned itself an IP address in the instead of asking the router for an addresses. Hence, router and other devices are unable to connect to FreedomBox.

@nomadicoder solution if spot on if you have recover from the situation. Alternatively, you can editing the connection file in directory /etc/NetworkManager/system-connections/ after plugging your FreedomBox SD card into another system.

Yes I just did as you said.
There were two files in system-connections directory.
I just deleted file called “FreedomBox Lan.nmconnection”
And finally my router finds my box.

1 Like

I had a problem where my FreedomBox disappears from the router each time the network is disconnected and reconnected.

Whenever there is a power outage of a few minutes (which might happen like once in a week at my place), the router is switched off but the Pioneer edition FreedomBox keeps running on battery power. Once the power comes back on, I found that the FreedomBox does not acquire an IP address from the router. A reboot of the FreedomBox device seems to fix this problem temporarily. I also tried rebooting the router but that has no effect.

I connected a monitor and keyboard to the FreedomBox device and found that the device eth0 has no carrier. I tried restarting the services networking and NetworkManager but that did not fix the problem.

I checked if it’s a broken upgrade by running sudo apt -f install. The package installation of freedombox 19.14~bpo10+1 was broken. I fixed it by running sudo dpkg --configure -a as prompted and rebooted the machine. I think the problem is solved for now.

If the problem is repeatable by turning off and on the router, please check dmesg/journalctl message if eth0: link up/down messages. If these message don’t appear as expected, it would explain why the connection was not brought up after the router started again.

freedombox package in an inconsistent state can not explain why NetworkManager did not do its duties. Apart from configuring the connections initially, freedombox package has no role in how network connections are brought up or managed.

I found an error message in dmesg output.

The problem seems to be consistently reproducible.

The broken install was an unrelated problem. A reboot fixes the ethernet issue.

Correction: This problem is not consistently reproducible. Ethernet doesn’t fail on every disconnection.