[SOLVED] Error installing apps

  • FreedomBox is plugged into a router at home
  • Running Freedombox 19.2 up to date


I am getting this error message when I try to install apps:

Error installing application: Error during installation E: Repository ‘http://security.debian.org/debian-security buster/updates InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘stable’

Any suggestions?

Thanks in advance.

1 Like

This requires a one-time manual step of accepting the change from testing to stable. This is basically triggered by Debian 10 becoming available.

I know one way of fixing it.

Login via SSH into your FreedomBox and run sudo apt update.
You will see a similar message as above. Not an error but a prompt with (y/n) to accept the change of the ‘Suite’ value from ‘testing’ to ‘stable’. Press y and enter.

After this all upgrades and installations should be working again.


This made me realize that setting the distribution to buster in Pioneer edition images also causes the future problem of not being able to upgrade to Debian 11 when it becomes available in 2 years.

Maybe it should be automatically changed from buster to stable in one of the updates.

1 Like

That worked great - thanks!

Worked for me too. Thank you!

Detailed announcement is here

I had a difficult time figuring this out; I had no idea where to find this stuff. Is it assuming that I’m logged in as a user that doesn’t have admin privilege? How do I find the user’s home directory? And where is the field for the SSH key in my Fbx admin user’s account?

On the plus side, I tried using the Terminal through Cockpit, and it looks like that worked.

1 Like

We need better documentation to talk about SSH keys and how to use them. Created an issue to track this: https://salsa.debian.org/freedombox-team/plinth/issues/1628

1 Like

I can’t log in to make the needed update.
On a perfectly fine password I get:

Permission denied, please try again.

I tried adding my public ssh key and get:

Unable to set SSH keys.

I enabled/disabled the SSH module and rebooted FreedomBox.

I can not log in with the password on the local machine that is connected to a TV set and a keyboard:

Login incorrect.

I can login to the webinterface with my password. I can even create new admin user and login to their webinterface, but not SSH and not locally.

@mray, could you try creating another admin user from the web interface and try with that user? Also try temporarily disabling ‘Restrict console logins’ option security.

Tried using a new created user already. Didn’t work.

Disabled both security settings, even rebooted after it. Didn’t work.

I also tried using cockpit, but could not install it due to said problem.

Since services stopped working, I expected that to be connected, turns out that for some reason ??? DynamicDNS got deactivated, just noting…

@mray Were there any errors shown in the web interface while creating the new user?

@sunil This looks like it has something to do with LDAP authentication since login from the web interface is working but console logins are not.

No, there were no errors shown.

I still don’t know a way to log in to my FreedomBox to do the manual update. How can I install new apps or update now?

What ended up being the solution to this problem? I am having the same issue. Login via web interface works fine, but can’t install apps and no SSH login.

I don’t know how it went with the login problem here, can only say I have similar problems in a VM and it’ related to systemd not booting up the system properly. Maybe 1-2 of 10 reboots would work.