Quassel client connection failure

I’m trying to connect to the quassel core I have installed on my freedombox.
I’m using pagekite for external connection. (I tried local connection too)
the username and password I use to connect to quassel are the same I use for the freedombox.

Yet I always get a connection refused error.

I followed no additional steps to configure quassel on the freedombox after installing it, as I could see no such interface.
I’m getting this problem using both quasseldroid and quassel-client on linux.

Where can I start to fix this? Is this a known issue?

Quassel does not run on HTTP(S) or SSH. It has it’s own port. So, it will not work with Pagekite. You best best is to use create an SSH tunnel and connect Quassel via that.

Quassel is not integrated into LDAP. So, it has it’s own username and password. I believe you will be setting this up the first time you connect to Quassel.

Since you are using Pagekite and your domain will be a pagekite provided domain, make sure you are using an Internal IP address to connect to Quassel service locally.

Thanks for the response.
Indeed, when I try to connect locally through the IP instead of just freedombox.local I get the initial configuration interface.

How can I go about setting up this SSH tunnel to connect from pagekite though?
(I’ve never set up such a thing)

1 Like

Umm… freedombox.local should have worked too! I wonder what went wrong there. Perhaps it is not a Linux/macOS machine on which it was tried?

For SSH tunnel, with an admin account you need to run the SSH command as follows:

ssh -L 4242:localhost:4242 -N myadminaccount@myfreedombox.example

You need use admin account to connect via SSH (or turn off restriction in Security page (not recommended)).

After successfully authenticating the command will wait. Then you can connect to Quassel on FreedomBox by connecting to domain “localhost” and port “4242”. You may be able to find apps for Android to open SSH tunnels in a similar way.

1 Like

Just tried again.
freedombox.local works on my linux machine, but not on my android phone.

I can’t seem to get ssh to work over Pagekite.
it keeps giving me this error:
ssh_exchange_identification: Connection closed by remote host