# Update - when to panic?

**URL:** https://discuss.freedombox.org/t/update-when-to-panic/2608
**Category:** Support
**Created:** [June 11, 2023, 2:23pm UTC](https://discuss.freedombox.org/t/update-when-to-panic/2608 "2023-06-11T14:23:39Z")
**Posts on this page:** 1
**Showing post:** 14

<div class="post-metadata">

### Author: ![Avron](https://discuss.freedombox.org/letter_avatar_proxy/v4/letter/a/a9adbd/32.png) [@Avron](https://discuss.freedombox.org/u/Avron)
#### Post date: [June 11, 2023, 8:33pm UTC](https://discuss.freedombox.org/t/update-when-to-panic/2608/14 "2023-06-11T20:33:25Z")

</div>

I ran

```auto
$ sudo su -
Password: <enter user password here>
# dpkg --configure -a
# apt update
# apt -f install
# unattended-upgrade --debug
# apt install freedombox
# apt update
# apt full-upgrade

```

After reboot, trying to reach the web interface gives an error that the server is not secure.

I have the following problem with apache2:

```auto
root@fbox:/etc/apache2# journalctl --follow --unit=apache2.service
Jun 11 21:58:11 fbox apache-error[1163]: [ssl:warn] [pid 1113:tid 1113] AH01909: fbox.mydomain.tld:443:0 server certificate does NOT include an ID which matches the server name
Jun 11 21:58:11 fbox apache-error[1163]: [ssl:error] [pid 1113:tid 1113] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: CN=freedombox / issuer: CN=freedombox / serial: 64EB79AF9D45607D587781C5FC38634604FB6FDA / notbefore: Jan 29 11:08:46 2023 GMT / notafter: Jan 26 11:08:46 2033 GMT]
Jun 11 21:58:11 fbox apache-error[1163]: [ssl:error] [pid 1113:tid 1113] AH02604: Unable to configure certificate fbox.mydomain.tld:443:0 for stapling
Jun 11 21:58:13 fbox systemd[1]: Started apache2.service - The Apache HTTP Server.
Jun 11 21:58:13 fbox apache-error[1168]: [ssl:warn] [pid 1167:tid 1167] AH01909: fbox.mydomain.tld:443:0 server certificate does NOT include an ID which matches the server name
Jun 11 21:58:13 fbox apache-error[1168]: [ssl:error] [pid 1167:tid 1167] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: CN=freedombox / issuer: CN=freedombox / serial: 64EB79AF9D45607D587781C5FC38634604FB6FDA / notbefore: Jan 29 11:08:46 2023 GMT / notafter: Jan 26 11:08:46 2033 GMT]
Jun 11 21:58:13 fbox apache-error[1168]: [ssl:error] [pid 1167:tid 1167] AH02604: Unable to configure certificate fbox.mydomain.tld:443:0 for stapling
Jun 11 21:58:13 fbox apache-error[1168]: [http2:warn] [pid 1167:tid 1167] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
Jun 11 21:58:17 fbox apache-error[1168]: [mpm_prefork:notice] [pid 1167:tid 1167] AH00163: Apache/2.4.57 (Debian) mod_auth_pubtkt/0.13 OpenSSL/3.0.9 configured -- resuming normal operations
Jun 11 21:58:17 fbox apache-error[1168]: [core:notice] [pid 1167:tid 1167] AH00094: Command line: '/usr/sbin/apache2'

```

I replaced my domain name with “mydomain.tld”. To reach my freedombox, I only type “[https://mydomain.eu](https://mydomain.eu)” not “[https://fbox.mydomain.eu](https://fbox.mydomain.eu)”. I don’t know whether this has anything to do with the issue (it used to work before upgrade).

EDIT: I did the following:

- re-apply the correction for [Failed to start Postfix Mail Transport Agent - #5 by sunil](https://discuss.freedombox.org/t/failed-to-start-postfix-mail-transport-agent/2337/5) as it was showing the same thing in the log
- change owner of .pem files in /etc/ejabberd/ to ejabberd instead of root (because in syslog there was a failure to read it), now ejabberd says it starts

Apparently, ejabberd and dovecot are running but they are unreachable ☹

---

_[View the full topic](https://discuss.freedombox.org/t/update-when-to-panic/2608)._
