Unable to acccess files on web server in "sharing" app

I have uploaded a folder for sharing app through plinth. i even set it to public access. I also tried changing the permissions as 777. I could see the files but could not access them.
Please help me resolve this.(i am trying to access it by connecting on local wifi connection setup.)


But when i click on the image file i could not access it.
the folder for sharing is this…

This looks like a bug although I cannot reproduce it with my version of freedombox (19.1). The file responsible for file share should be in /etc/apache2/conf-avalable/sharing-freedombox.conf. Can you check and post the contents in it?

Please also provide the related version of FreedomBox you are using and/or how you installed it.

The content in the above mentioned folder is :

Alias /share/test1 /qwerty
<Location /share/test1>
Include includes/freedombox-sharing.conf
Require all granted

Also i dont know how to check the version as i am a newbie to linux.
i installed fbx by setting password to image file and through dd command in live user session of ubuntu.

I installed the image a month before.
it is most probably 19.0 version.

Sorry i got that solved after i modified that file permission . previously I modilied the directory permission onlly. now i set each and every file permission in it to 777.
But my opinion is that if for a commmon user’s usage…The plinth interface itself should change permissions if sharing is set to public access. :slight_smile: