[Solved] "Wifi only" not working

Hi folks!

I’ve tried the Freedombox on a Pine A64+ and a Raspberry 3 B+ and everything seems to work fine (except coquelicot, so sad…): connecting succesfully by its static ip within the home network and by dyn dns domain.

But I want to use the Freedombox over Wifi as it should not stand near the router and I don’t want to lay a long ethernet cable.

On both, Pine and Pi, I’ve tried it using an USB-Wifi-Dongle (Edimax EW-7811Un, realtek-driver).

The result is the same: the Freedombox can connect with the wifi but drops the connection after a few seconds. I’ve rebooted the Freedombox, unplugged the ethernet cable but the Freedombox is not reachable by it’s static ip or domain. I don’t know if it tries to connect automatically and drops the wifi connection or if it does not even try to connect.

Maybe it is intended, to use the Freedombox only by LAN?
Or is it the wifi dongle? Can you recommend one?

Thank you in advance!!

Information

  • FreedomBox version: 19.1
  • Hardware: Raspberry Pi 3 B+, Pine A64+ 1GB
  • How did you install FreedomBox?: downloading testing images from https://freedombox.org

Edimax EW-7811Un seems to be using Realtek rtl8192cu Linux driver. Unfortunately, like most Wi-Fi chipsets, it requires non-free (proprietary) firmware. See Debian wiki page on this. Package you need is firmware-realtek. Once the firmware is available on the system, reboot it once and you should see the interface listed in the output ip link command. After this, you can use the FreedomBox Web UI or command line tools nmtui and nmcli to configure the interface to connect to your router. This process is similar to connecting a desktop machine to your router.

FreedomBox is a regular Debian setup that uses NetworkManager. There is nothing that prevents you from using an Wi-Fi dongle and restrict you to LAN. I used to have a AR9271 based Wi-Fi dongle in my setup as an access point (had some issues with it).

We recommend Wi-Fi devices that don’t need non-free firmware and run fully using free software. There are, however, some limitations to these hardware.

Thank you for your prompt answer, Sunil!

I’ve bought the Edimax EW-7811Un, because it was advertised as being “ideal for Rasberry Pi”.

The Freedombox is able to connect to the routers WLAN, but disconnects after a few seconds. That happend on the Raspberry Pi as well as on the Pine. Maybe that dongle is not that “ideal” :roll_eyes:

I hope to get a Wi-Fi dongle with one of the Atheros chipsets. Perhaps they are also more stable. :smirk:

Thanks again!

When you say it connected, you are able to connect to other machines or browse internet before disconnect, right?

I want to pass on two hints for debugging:

  • One important thing to worry about is the power supply requirements. Sometimes, poor power supply leads to board and device together not getting enough power. If your power supply is of poor quality it may not be providing as much as it is rated for. Also, if it is rated just enough for the board, as far as I know, we need to calculate more for additional USB devices we connect.
  • Follow the outputs of journalctl -f and dmesg -w while the connection and disconnection process is happening. It might give us hints about why the disconnect is happening. Perhaps post those logs here and others can take a look. If nothing works, you can always try a different adapter :slight_smile:

The problem is solved! :tada:

When I tried to connect the Freedombox with the router by Wi-Fi using the Web UI, it said the connection is active but a few seconds later it was disconnected.

I tried a stronger power adapter but had no luck.

I’m mainly a desktop user and not very experienced using command line tools (not to mention that I don’t even know how to take a look into the log). Accordingly, thank you very much for suggesting using journalctl -f and dmesg -w. It is very interesting to see the machine working and eager giving you so much information which the Web GUI is not able to accomplish.

In both outputs there were the reports:
aborting authentication with [...] by local choice (Reason: 3=DEAUTH_LEAVING)

I looked for the error and if I got it right, the reason for the unsuccessful connection was a security feature. With every connect a new MAC address is generated and some Wi-Fi adapters have a problem with it.

So I had to turn that off by adding the following to /etc/NetworkManager/NetworkManager.conf:

[device]
wifi.scan-rand-mac-address=no

Now the connection is stable and I can use it the way I wanted to. :grin:

I hope, this helps, if someone encounters the same problem. :+1:

2 Likes

I added this information to Networks manual page. Thanks a lot for posting the solution.

1 Like

I am pleased that I was able to contribute to the project. :slightly_smiling_face: