[SOLVED] Error message installing Matrix Synapse app on Freedombox/Raspberry Pi3B (Rasbian Buster)

Hello, I have been getting a lot out of Freedombox on a Raspberry Pi3B home DDNS set up.
I have been using an XMPP set up with the eJabberd server, which has been great for end-to-end encrypted text messaging, with combinations of various mobile and desktop apps. Unfortunately, I can not find a combination of XMPP apps that will provide reliable voice chat from Android to iPhone (I’ve tried a lot of combinations!) so I have started to look into Matrix Synapse/Riot for encrypted text chat and voice/video chat.

Unfortunately, when I try to install Matrix Synapse via the Freedombox GUI on the Pi3B I get the following error message: “Error installing application: Error during installation E: Unable to correct problems, you have held broken packages.”

I am guessing this is because there is not a complied package for the Pi’s ARMv8-A (64/32-bit) instruction set/processor (are these the same thing?!).

I have had a look at the following blog that provides instructions to compile Matrix Synapse for the Pi but it is a bit daunting: https://www.mytinydc.com/en/blog/matrix-synapse-installationserver-riotclient/

My questions are:

  • am I right that there are currently no complied Matrix Synapse packages for the Pi hardware?;
  • if so, are there any plans to provide Matrix Synapse packages for the Pi?;
  • if not, might someone here help me with compiling the Matrix Synapse packages for the Pi and help configure the setup (it is the configuration that I’m most daunted by!)?

I currently have Freedombox (eJabberd, Mumble and File Sharing), Nextcloud and Talk (which I have had mixed results with!) and Wordpress all running nice and stably from the same Pi3B and I had hoped a one click install of Matrix Synapse would be a great edition to my set up. I’m worried that if I have to compile and manually configure the set up I might mess up my current services.

Thanks in advance


I have the same problem with my Pioneer Freedombox. What i found on this forum;
[SOLVED] How to upgrade matrix-synapse from stable to buster-backports? .

After running this; apt-get -t buster-backports install matrix-synapse in the terminal, I was able to install the application in the Freedombox GUI.

I hope this helps

1 Like

Awesome thanks - that has fixed it.