Problems with DNS records for postfix

After enabling Postfix/Dovecot, it is indicated a list of DNS records that need to be added.

In the list, there is

  • an MX record targeting the freedombox (FQDN of the freedombox) with “domain” set as empty
  • a TXT record “v=spf1 mx a ~all” with “domain” set as empty
  • a TXT record with domain set as _dmarc
  • a TXT record with domain set as dkim._domainkey
  • a SRV record with domain set as _submission_tcp
  • a SRV record with domain set as _imaps_tcp
  • a SRV record with domain set as _popo3s_tcp

In my case, the freedombox name is fbox.mydomain.mytld but I already have MX records for mydomain.mytld. with, as target, a server handling user@mydomain.mytld addresses.

So I assume the MX record in the above list is incorrect: I need to indicate not only fbox.mydomain.mytld. as target but also as domain, so that it only applies to the subdomain. Is that correct? And probably the same for the second record.

However, how to correct the records that have a non-empty domain i.e. _dmarc, dkim._domainkey, _submission._tcp, _imaps._tcp and _pop3s._tcp ? Should I add a fbox.mydomain.mytld. prefix to the “domain” of all these records, e.g. fbox.mydomain.mytld._dmarc, fbox.mydomain.mytld.dkim._domainkey, etc ?

I changed _dmarc to _dmarc.fbox.mydomain.mytld, dkim._domainkey to dkim._domainkey.fbox.mydomain.mytld, etc.

I tried to send email and reply, it worked, so perhaps this is the correct way. If so, that should be corrected.

With respect to the dkim._domainkey record: as it is proposed, it is rejected by the interface of my DNS provider. It works when removing the two quotes (the " character) in the middle. Perhaps some hint about this could be added.

I’ll continue to try, but it looks nice, thanks to all who worked to make this possible !