Problems Installing FreedomBox on PINEA64+

Hi all,

I’m currently trying to install FreedomBox on a PINEA64+ 1GB board. I followed the instructions on the Wiki using the stable 64-bit x86 image. I followed all the steps the manual mentioned. Everything worked like it was supposed to until I tried to log into Plinth for the first time. I can’t find any evidence of the box on my home network. I checked through my router and using nmap, and I can’t see it. The lights on the LAN port aren’t lighting up. The power LED on the board itself is lit. I can’t get any output out of the box using any of the ports. Did I mess up copying the image? Or is the board fried? What can I do to diagnose the issue?

Hello, PineA64+ requires the ‘pine64-plus’ image and 64-bit x86 image will not work for it. Also we recently started building image for PineA64 and so stable images are not available for it. You need to pick testing images:

Gotcha, thanks. I’ll try those images.

-Alex W.

Still having issues. Now the router’s ethernet light is on when the box is connected. Also the data on the SD card looks right. I still can’t find the box on the network. Any suggestions for trouble shooting? Thank you for your help.

Update
I managed to install Debian and get that working so my hardware seems to be fine. I currently don’t have a HDMI monitor that is portable enough (I’m currently using my TV.) to get into the same room as my router so I can’t get online and try installing the package until I get a USB wifi antenna or a new monitor. If anyone has any insights as to why the image for my hardware wasn’t working. I’m all ears. Otherwise I’ll check in when I get online.

I have recently tested those Pine64+ images and have some confidence on them. Some tips for further debugging:

  • Don’t expect HDMI output on the FreedomBox image, it has not been tested. Just try to find it on the network and use the URL to reach it. Attempt SSH connection after initial configuration only.
  • Ensure that your work machine and Pine64+ board are connected to same network.
  • Login to the router and see if FreedomBox running on Pine64+ is trying to acquire IP address during it’s boot and use that IP address to connect to FreedomBox.
  • Ensure that you have waited at least 10minutes after the first boot before trying to reach the box.
  • Make sure you have written the image to SD card properly (and not copied it). Use the Etcher tool to be sure.
  • As a last resort, try to connect the Pine64+ board to a TTL serial cable and get the debug logs. This is how we debug the board when building support for it. This will clearly tell us what the problem is.