No LDAP Users created? Can't SSH into FB

Problem Description
I’ve setup a FreedomBox 21 and the Web-Interface works fine, but Login into Cockpit or SSH does not. My Admin-Users - the initial and a second - can both login into the Web-Interface and add Apps, like e.g. Matrix or Gitweb, but they cannot login via SSH or Cockpit.

Steps to Reproduce
I would have to reproduce it my self again to be certain, but I’ve used the FreedomBox-Image of mid December on an SD-Card with an RaspberryPi and updated until Version 21.

Create a new users and get the same error as seen in appended Screenshot.

Although reason is “Invalid Credentials” at least the Web-User is created.

I can login with all created users into the web-interface but not via ssh. Regardless of security settings limiting to “admin” group.

Expected Results
LDAP User is created. SSH login is possible.

Actual results
No LDAP User is created. SSH login is not possible.



With no solution at hand, I’ve recreated a new Freedombox on a new SD-Card and made sure to not have my Keyboard plugged in (had my wireless connector still plugged in the first time).

I am not sure if that was the problem, I may try to recreate it, but for now, all ist good thanks to the backup functions of freedombox which still worked and allowed me to migrate my already setup apps.