No Internet acces after install

I installed Freedombox on a fresh install of Debian Stretch trough apt-get.
Everything worked fine until after the installation of the freedombox packages.
I can log into the web interface without problem.
However connecting to the internet is no longer possible from the server.
On the commandline I get the following errors when trying to run “apt-get update”:

root@servername:/home/userl# apt-get update Err:1 stretch/updates InRelease Could not resolve '' Err:2 stretch InRelease Could not resolve '' Err:3 stretch-updates InRelease Could not resolve '' Reading package lists... Done W: Failed to fetch Could not resolve '' W: Failed to fetch Could not resolve '' W: Failed to fetch Could not resolve '' W: Some index files failed to download. They have been ignored, or old ones used instead.'

In fact it seems Domain names can’t be resolved anymore.
Ip adresses are still working fine.

I duck duck go’d around but couldn’t find a solution.

Anyone any ideas?


Let’s confirm that this is a DNS resolution problem. Try this:


Press Ctrl+C after a few lines and see the results. If there’s 0% packet loss, then you have a working Internet connection but your FreedomBox is unable to resolve domain names. Otherwise, it’s an Internet connection problem.

I did a test yesterday with ping wich worked fine.
Tour be sure I tried again with
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=58 time=25.6 ms
64 bytes from icmp_seq=2 ttl=58 time=24.8 ms
64 bytes from icmp_seq=3 ttl=58 time=25.3 ms
64 bytes from icmp_seq=4 ttl=58 time=25.2 ms
64 bytes from icmp_seq=5 ttl=58 time=24.7 ms
64 bytes from icmp_seq=6 ttl=58 time=24.7 ms
64 bytes from icmp_seq=7 ttl=58 time=25.3 ms
— ping statistics —
7 packets transmitted, 7 received, 0% packet loss, time 6019ms
rtt min/avg/max/mdev = 24.735/25.140/25.661/0.322 ms

I am not sure what further logs or info would be helpfull here.

One thing you could try is to set an explicit DNS server. For this, go to system, networks, click on a connection, Edit, Set the DNS server to ‘’, then click ‘Edit Connection’. After this restart your FreedomBox from top right menu.

Still nothing.
I found this under Diagnostics:

What is the output of cat /etc/resolv.conf. If this does not show nameserver after your changes, then something wrong with the editing process, I guess. You can also add this line to the file to temporarily get connectivity (it will be overwritten later).

Also System -> Networks -> Click on Network Connection: should show IPv4 DNS server as after your changes.

The nameserver was not included in resolv.conf.
Manually editing the file solved it.
For completion sake, this was the content of the network connection:

I totally missed the part where you said you installed freedombox using apt-get. If you already have a Debian system configured with network and install FreedomBox, then FreedomBox (which essentially uses Network Manager) does not touch your existing network setup at all. This is why we see ‘unmanaged’ in the state above.

Your network configuration will be in /etc/network/interfaces or /etc/network/interfaces.d/*. You can continue to use Debian’s plan old way of configuring the interface by editing those files. Add your DNS server there. See Debian documentation for this.

Alternatively, if you remove those files (or move them out), then Network Manager will take over on next reboot and do an automatic DHCP configuration for the network interface. After this, you can assign firewall zone (‘internal’ or ‘external’) and setup a custom DNS server if needed using the FreedomBox web interface. If something goes wrong, you can replace the files back into /etc/network/ and reboot to get back your old setup.

I indeed already had a static ip config on Debian.
However I never touched the nameserver configuration as everything worked out of the box.
Only after running the install script for freedombox the system stopped finding domain names.

I may be out-of-date here, but I think FreedomBox might touch your network config in some circumstances. I think it will not use ifconfig, which is the default for the standard Debian install. It uses Nmcli, which it attempts to set up by itself using dhcp with no reference to the ifconfig settings. It does not detect a dhcp failure and warn of this, and may have some problems with static IPs. See bug 898237 and the last para of these install instructions. The second-last para of those instructions also says “Freedombox does not support network device configuration via /etc/network/interfaces”; possibly this needs updating?