# FreedomBox 24.9 released

**URL:** https://discuss.freedombox.org/t/freedombox-24-9-released/3029
**Category:** Announcements
**Created:** [April 23, 2024, 1:49am UTC](https://discuss.freedombox.org/t/freedombox-24-9-released/3029 "2024-04-23T01:49:58Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![jvalleroy](https://discuss.freedombox.org/user_avatar/discuss.freedombox.org/jvalleroy/32/331_2.png) [@jvalleroy](https://discuss.freedombox.org/u/jvalleroy)
#### Post date: [April 23, 2024, 1:49am UTC](https://discuss.freedombox.org/t/freedombox-24-9-released/3029/1 "2024-04-23T01:49:58Z")

</div>

FreedomBox 24.9 has been released and uploaded to Debian unstable. Typically, the freedombox package will migrate to testing in 2 days, and then can be uploaded to stable-backports.

Changes in this release:

- action\_utils, nextcloud: Make podman util more generic
- config: Handle dropin config files with limited permissions
- locale: Update translations for Albanian, Chinese (Simplified), Chinese (Traditional), Russian, Spanish, Turkish
- nextcloud: (Note that this app is currently disabled, and not available to install.)
  - Add network interface to firewall zone after creating it
  - Add warning that the app is experimental
  - Allow backup/restore when app is disabled
  - Connect to mysql using socket instead of TCP
  - Connect to redis using Unix socket
  - Connect to slapd for LDAP using Unix socket
  - Don’t fail uninstall if DB or user do not exist
  - Don’t set password on redis server
  - Don’t show incorrect phone region when it is not set
  - Drop a repeated creation of systemd service file
  - Ensure that database is running when running setup
  - Expand on the warning about container usage
  - Fail on errors when configuring the app
  - Fix configuring trusted proxies setting
  - Improve check used to test if installation wizard is done
  - Improve database permission granting
  - Improve setting up LDAP configuration
  - Minor changes to cron timer units
  - Minor refactoring
  - Minor update to description regarding users’ usage
  - Refactor container creation code
  - Refactor setting admin password
  - Remove fail2ban jail, brute force protection present
  - Rename the systemd service names
  - Retrieve database password in a more robust way
  - Use a separate DB for redis
  - Use secrets module generate passwords
  - When backup fails, unset the maintenance mode

- tests: functional: Disable functional tests

The following people contributed to the git repository for this release:

- Besnik Bleta
- Burak Yavuz
- gallegonovato
- James Valleroy
- Joseph Nuthalapati
- Ray Kuo
- Sunil Mohan Adapa
- Yurt Page
- 大王叫我来巡山
