Fbx instead of my username in local shares

Dear support team, dear community:

  • FreedomBox is plugged into a router at home.
  • Got the Freedombox in June
  • FreedomBox Version 19.20
    When I try to open freedombox in Nautilus (other locations), only user fbx shows up per default.
    My user created at setup does not show.
    What did I forget/how can i fix that?
    Is there a chance, to make this dau-friendly per default?
    Thanx for your help and time.

@hanstux I believe the user’s home directory (/home/username) is created only when the user first logs in through SSH or Cockpit terminal. (Logging in through the web interface won’t cause the home directory to be created.)

Could you try log in through one of these methods, and see if it creates the directory?

Dear james, I tried as you suggested, but no luck here. I deleted user fbx, but still get asked for the password of fbx on freedombox.
Added another user in plinth/system, which does not create a homedirectory for that user.
On ssh adduser it says, "the user ‘user’ allready exists.

It is a bug in Freedombox that the file browser asks for a unknown user password (https://salsa.debian.org/freedombox-team/plinth/issues/1689)

You can connect to the FreedomBox with Nautilus if you press CTRL + L and insert following address to the location bar:


Replace ‘veiko’ with your username (it should be the same user you login into Plinth web page) and replace ‘mybox’ with your FreedomBox name (it is the name Nautilus showed in Other Locations). mybox.local can be replaced also with an IP address your FreedomBox have.

1 Like