Excited to be here

#1

I’m an old school American Unix veteran. I first used Unix in 1982, Fortune Systems 32:16. I worked at Locus Computing (1990-1991) , then Sun Microsystems (1991-1996), then NetPower, then BEA systems 1997-2000. In my career I have met Bill Gates, Steve Jobs, Bill Joy, Scott McNeally, James Gosling. I have exchanges with Bjarne Stroustrup (c++) on reddit.

I was RadBrad on Stackoverflow, Ruby on Rails expert, I lost access to the account in 2013, but it is still good!

I’m going to test the snot out of ruby, then RoR

But as of now, I can’t get cockpit to work, as it is the only way I see to get a shell as root.

2 Likes
#2

Did you try ssh with your user name then sudo su?

#3

Yea, I can ssh in now, didn’t realize it was enabled

cockpit screen is completely blank after I login to it still though, even though I don’t care now.

Can I reset a FreedomBox? I want to create a DMZ and initialize it on that network

#4

Thanks for joining our community! We are happy to welcome a veteran with such a distinguished career :sunglasses:

Yes, this issue was reported by another user who was using a Pioneer Edition FreedomBox sold by Olimex. Our development team followed up and confirmed that the issue does exist but is not permanent. We were able to confirm that Cockpit’s interface does not show up when you try to access it for the first time on a Pioneer Edition LIME2. But if you refresh the page, it should work. I can confirm that I can now access Cockpit on my Pioneer edition FreedomBox.

As one of our developers told me: “I also saw this problem on the Pioneer kit. But after reloading the page once, the issue goes away, and I’m able to log in.”

I found that the problem was solved after I shut down, unplugged, and plugged back in my FreedomBox (I was shutting down for a reason unrelated to Cockpit, though). Once my FreedomBox powered on again, Cockpit was accessible and I can now use it.

(P.S., In the future when you need support, please make sure to post your topics in the relevant categorie. Owners of the Pioneer Edition FreedomBox can post in this category and all other technical support issues can be posted in the general support category.