Edit/add user account: Authorization password failing

FreedomBox is plugged into a router at home
Bought kit nov '20
Running latest version 20.20.1
Pagekite installed and domain active
Tried things both via local access and via Pagekite

Created an account with admin permissions during setup.

Would like to edit account’s password (via plinth/sys/users/user/edit/) and add a second user (via plinth/sys/users/create/).

Would like to accomplish a Debian recommended setup of two users: an admin user with minimal access time and a ‘daily’ user.

I use the password that I created during setup to change these settings, considering it to be the Authorization password.

When submitting the Authorization password on both pages, it gives: " Invalid password. Enter your current password to authorize account modifications."

I very thoroughly checked my password, it is the correct one. Am I missing something here? Is there maybe a default, universal freedombox password that I somehow missed?

Then, I tried changing the current password via ssh. It did change the password in ssh. Logging in through ssh requires me to provide the new password.

However, I can only log in my freedombox (browser/plinth) with the password that I created previously, i.e. during device setup.

The invalid authorization password errors remain the same, when trying to add a user or edit my current and new password.

Please reset your admin account password according to https://wiki.debian.org/FreedomBox/QuestionsAndAnswers#I_forgot_the_password_for_my_admin_account._Can_I_reset_it.3F

Then again try to create a second user. If the authorization password still fails, see if there are any errors in the logs - check the journalctl -e command and the /var/log/auth.log file

1 Like

@vexch, thank your for your answer.

I consider the problem solved. Trying to keep it as short as possible, but then again, I want to support other novices that may run into similar issues.

A recap.

The issue shipped with the ordered Olimex Pioneer edition.

I tried to solve the issue by manually flashing the box with the stable Pioneer image dated 2019-07-19 to be found on freedombox.org/download/pioneer/. Since it is the img that is presented on that page, I considered it to be suitable.

The issue arrived again while using that image.

I posted my question here.

Followed your advice. Followed the instructions, but stumbled upon serveral errors. ldapresetpasswd command not found. Provided the username, it was not recognized etc. Also downloaded sqlite, created the .py file etc. Am able to provide some terminal outcomes if that is of interest of anyone. Am willing to learn from it!

Then on the download page, tried ‘more download options’ and landed on freedombox.org/pub/freedombox/pioneer/weekly/.
Installed most recent img.

Editing passwords and adding/removing users works fine in Plinth. And obviously the initial update was a breeze compared to the 2019 img.