Can't access web interface for initial setup

Im using an olinuxino a20 lime2 with image from freedombox.org
Box boots ok and stop on tty1 login.
I try to access the interface trough 10.42.0.1 and freedombox.local, none works.
There’s no dhcp lease on router.
The eth led stays green but rarely blinks.

syslog:
https://pastebin.com/bfbDMVU6

edit:
I edited /etc/network/interfaces.d/box to get a static ip, now the router sees me but I’m still unable to access the page.
I’m using openwrt, already tried some firewall configurations, devices are able to ping each other, except for the box.

Can you check the revision of your Lime 2 board? It is printed on the board on the top side under “A20-OLinuXino-Lime2”.

Did you install the stable version of FreedomBox?

Hello, it’s revision K.
Jonas said on irc that a temporary solution would be to set the link to 10M, that’s what I did and it worked.
It’s not optimal, I’m waiting for a better solution, but at least I can play with the box now
edit: yes, it’s the stable version

1 Like

As you told that there is no dhcp. I can suggest you a little thing. Why dont you login to ttyl and open networkmanager and set ip etc., manually.
To do so use the command “nmtui” in sudo

I had no access to tty at the time, because the root account had no password, so was locked, and the fbx is not accessible on normal setup.
I could have done this:
https://wiki.debian.org/FreedomBox/Manual/SecureShell
But I just saw it later, so I found a solution.
~ plugged the sdcard to another computer
~ copied hash pw from /etc/shadows from one of my accounts and pasted it on shadows from sdcard, on the root line
Than I could log as root and set up the static ip. At this time i could have used nmtui (if it was already installed), but I didn’t knew the command.
Thanks for the help.
Now everything is working, I’m very happy with the apps, just need a better connection, because freedombox(or the firmware, idk) on my board revision just connects if I force the link to 1 megabit(?).

1 Like